const regex = /^((?:\w+\.)*(?:(?:\w+)+))\.(?:\d\.\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:\\w+\\.)*(?:(?:\\w+)+))\\.(?:\\d\\.\\w+)$', 'gm')
const str = `items.very.nested.path
items.1.come.hhhh.asd
items.1.come.1
items.1.come.1.field
items.path.come.1.field
items.1.field`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}