# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/O(?<=^.{0,8})/0/gm;t' <<< "C099900XABCD
O099900XABCD
CO99900XABCD
C0O9900XABCD
C09O900XABCD
C099O00XABCD
C0999O0XABCD
C09990OXABCD
C099900OABCD
C099900XOBCD
C099900XAOCD
C099900XABOD
C099900XABCO"