const regex = /.*\.(js\?.*|js|otf|gif|png|jpg|svg|bmp|css|jpeg|pdf|ico|eot|woff|woff2|axd|ttf|gif\?.*|png\?.*|jpg\?.*|svg\?.*|bmp\?.*|css\?.*|jpeg\?.*|pdf\?.*|ico\?.*|eot\?.*|woff\?.*|woff2\?.*|axd\?.*|ttf\?.*|otf\?.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\.(js\\?.*|js|otf|gif|png|jpg|svg|bmp|css|jpeg|pdf|ico|eot|woff|woff2|axd|ttf|gif\\?.*|png\\?.*|jpg\\?.*|svg\\?.*|bmp\\?.*|css\\?.*|jpeg\\?.*|pdf\\?.*|ico\\?.*|eot\\?.*|woff\\?.*|woff2\\?.*|axd\\?.*|ttf\\?.*|otf\\?.*)$', 'gm')
const str = `https://i.dell.com/sites/csimages/UberHomePage_Imagery/all/keyboard-mouse-icon.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}