#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"[[:blank:]\h]{0,2}" & @CRLF & _
"(?<!\\)" & @CRLF & _
"(?<line_all>" & @CRLF & _
" [[:blank:]\h]?" & @CRLF & _
" (?<line_type>\*|\-|\_)" & @CRLF & _
" [[:blank:]\h]?" & @CRLF & _
"){3,}" & @CRLF & _
"[ \t]*" & @CRLF & _
"$"
Local $sString = "* * *" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")