using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s+|\s+$|\s+(?=\s)(?=(?:[^\""]*\""[^\""]*\"")*[^\""]*$)";
string substitution = @"";
string input = @" Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque sagittis semper ipsum at consectetur.
Fusce mauris "" don't modify the space between quotes like this "" massa, elementum id neque vel, facilisis ultrices enim. ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}