const regex = new RegExp('^\\s+|\\s+$|\\s+(?=\\s)(?=(?:[^\\"]*\\"[^\\"]*\\")*[^\\"]*$)', 'g')
const str = ` Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque sagittis semper ipsum at consectetur.
Fusce mauris " don't modify the space between quotes like this " massa, elementum id neque vel, facilisis ultrices enim. `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);