# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(€)(\w*)[.]?(\w*)/\2,\3\1/g;t' <<< "€11.99
€99"