package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(€)(\w*)[.]?(\w*)`)
var str = `€11.99
€99`
var substitution = "\2,\3\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}