use strict;
my $str = '€11.99
€99';
my $regex = qr/(€)(\w*)[.]?(\w*)/p;
my $subst = '\\2,\\3\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";