import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".{1,}?([。.」??!!]+|\\n)";
final String string = " そこは純白の空間だった。\n\n"
+ " 四方の壁は継ぎ目の無い白塗り、中央に鎮座する祭壇も雪を固めたように真っ白で、この部屋を満たす光もまた白く輝いていた。\n\n"
+ "「供物を捧げよ」\n\n"
+ " どこからとも無く部屋中に響き渡る声。\n\n"
+ " 開け放たれた両開きの扉、その暗い通路の向こうから人の列がやってくる。白い部屋と同じように、その人々もまた白尽くめであった。\n\n"
+ "染み一つ無い清潔な白いローブで全身を覆い、顔には白いマスクを被り、素肌を露出している部分が一切無い。";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}