# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:^[ \t]*(?P<complete>x))|
(?P<priority>\(\w+\))|
(?:(?P<CoDate>\d{4}-\d\d-\d\d)[ \t]*(?P<CrDate>\d{4}-\d\d-\d\d)?)|
(?P<task>[\w']+(?:[.,; \t-]+[\w']+)*\b(?!:))|
(?P<Project>\+\w+)|
(?P<context>@\w+)|
(?P<meta>[a-zA-Z]+:[\w-]*)
"""
test_str = ("(A) Thank Mom for the meatballs @phone\n"
"(B) Schedule Goodwill pickup +GarageSale @phone\n"
"Post signs around the neighborhood +GarageSale\n"
"@GroceryStore Eskimo pies\n\n"
"Really gotta call Mom (A) @phone @someday\n"
"(b) Get back to the boss\n"
"(B) Submit TPS report\n\n"
"x 2011-03-03 Call Mom due:2010-01-02 again:thisOne\n\n"
"x 2011-03-02 2011-03-01 Review Tim's pull request +TodoTxtTouch @github\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.