re = /P(\d{1,}.\d{1,}) (?<=)of(?= to)/m
str = 'You have paid P85.00 of GCash to Total NLEX Bonjour on 12-30-19 05:51:47 PM. Ref. No. 914311523.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end