# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^DATE:.*((?:\n(?!AREA:).*)+)"
test_str = ("AREA: OMBEYI MARKET, ST. RITA RAMULA\n\n"
"DATE: Thursday 25.03.2021, TIME: 9.00 A.M. = 5.00 P.M.\n\n"
"Ombeyi Mk, Kiliti Mkt, Masogo Mkt, Miwani, Kasongo, Onyango Midika, St. Rita Ramula, Onyalo\n"
"Biro, Yawo Pri, Obino, Rutek, Keyo Pri & adjacent customers.\n\n"
"AREA: NYAMACHE FACTORY\n\n"
"DATE: Thursday 25.03.2021, TIME: 830 A.M. - 3.00 P.M.\n\n"
"Nyamache Fact, Suguta, Gionseri, Igare, Kionduso, Nyationgongo, Enchoro, Kebuko, Emenwa, Maji\n"
"Mazuri, Borangi & adjacent customers.\n\n"
"AREA: SUNEKA MARKET, RIANA MARKET\n\n"
"DATE: Thursday 25.03.2021, TIME: 8.00 A.M. - 3.00 P.M.\n\n"
"Suneka Mk, Riana Mk, Kiabusura, Gesonso, Chisaro, Sugunana, Nyamira Ndogo & adjacent\n"
"customers.\n\n"
"AREA: ITIATI, GITUNDUTI\n\n"
"DATE: Thursday 25.03.2021, TIME: 9.00 A.M. = 2.00 P.M.\n\n"
"General China, Gachuiro, Gathuini Pri, Itiati Campus, Kianjugum, Gikore, Kihuri TBC, Gitunduti &\n"
"adjacent customers.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.