const regex = /[A-Za-z0-9\xf6\xd6\xc7\xe7\u015e\u015f\u011e\u011f\u0130\u0131\xdc\xfc_]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z0-9\\xf6\\xd6\\xc7\\xe7\\u015e\\u015f\\u011e\\u011f\\u0130\\u0131\\xdc\\xfc_]', 'g')
const str = `öÖÇ窺ĞğİıÜüş or ğ it is`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}