#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)object\/(?:custom|standard)\/(.*?(?=\/type[ab]|$))(?:\/(type[ab])(?:\/(.*))?)?"
Local $sString = "Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept" & @CRLF & _
"" & @CRLF & _
"object/custom/name1/name2" & @CRLF & _
"object/custom/name1/name2/typea" & @CRLF & _
"object/custom/name1/name2/typea/item"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")