import Foundation
let pattern = #"\s\S+?\$info_max_time\$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
yolo _time<=$info_max_time$ (index=* OR index=_*) $threat_match_value$ [search _time=2022-09-26T11:17:12.000-07:00 index=threat_activity | head 1 | `makemv(orig_sourcetype)` | rename orig_sourcetype as sourcetype | mvexpand sourcetype | return 100 sourcetype]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)