import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=class=\"four-column mosaicElement\")[\\s\\S]*?href=\"\\s*(https?[^\\s]+)\\s*\"";
final String string = "<li class=\"four-column mosaicElement\">\n"
+ "<a href=\"https://example.com\" title=\"Lorem ipsum\">\n"
+ "...\n"
+ "</a>\n"
+ "</li>\n"
+ "<li class=\"four-column mosaicElement\">\n"
+ "<a href=\"https://example.org\" title=\"Lorem ipsum\">\n\n"
+ "<li class=\"four-column mosaicElement\">\n"
+ "<a href=\" https://example.org \" title=\"Lorem ipsum\">\n\n"
+ "<li class=\"four-column mosaicElement\">\n"
+ "<a href=\" https://example.org \" title=\"Lorem ipsum\">\n"
+ "...\n"
+ "</a>\n"
+ "</li>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}