package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Group:\s(\w+) \|SubGroup:\s(\w*)`)
var str = `Group: i_am_group |SubGroup: i_am_sub_group`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}