re = /\b0\d/m
str = '# bad
FOO=01
FOO=1,02,3
FOO=[1,02,3]
# good
FOO=1
FOO=[0,1,0,2,0,3]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end