Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([\[].+?[\]])(:\d+)?
/
g
Test String
New
India , officially the Republic of India (Hindi: Bharat Ga ? arajya), is a country in South Asia. It is the seventh-largest country by area, the second-most populous country, and the most populous democracy in the world. Bounded by the Indian Ocean on the south, the Arabian Sea on the south asdlfasjdflksd [2] slkdjwed[3223][123][jhhjkzu7] some references have a page number: [678]:7898[rtzu] (lis jkjkh j k lis jkjkh j k ? ten ? ten)hjjh jgj jh g[456]h (jjhhzjhkjjk) [g][45]:789