const regex = /(.*)(?:\bm\.)(.*)|(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)(?:\\bm\\.)(.*)|(.*)', 'gm')
const str = `https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php
https://redfm.ie/
https://en.m.wikipedia.org/`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);