// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)(?:\bm\.)(.*)|(.*)").unwrap();
let string = "https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php
https://redfm.ie/
https://en.m.wikipedia.org/";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}