#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms).*?"(\w+)".*?{(.*)}"
Local $sString = "// Rewrite of Crystal Maiden Frostbite" & @CRLF & _
"// Author: kritth" & @CRLF & _
"// Date: December 31, 2015" & @CRLF & _
"// Version: 6.86" & @CRLF & _
"// Type: Datadriven" & @CRLF & _
""flower_maiden_rooting_shoot"" & @CRLF & _
"{" & @CRLF & _
" // General" & @CRLF & _
" //-------------------------------------------------------------------------------------------------------------" & @CRLF & _
" "BaseClass" "ability_datadriven"" & @CRLF & _
" "AbilityType" "DOTA_ABILITY_TYPE_BASIC"" & @CRLF & _
" "AbilityBehavior" "DOTA_ABILITY_BEHAVIOR_UNIT_TARGET"" & @CRLF & _
" "AbilityUnitTargetTeam" "DOTA_UNIT_TARGET_TEAM_ENEMY"" & @CRLF & _
" "AbilityUnitTargetType" "DOTA_UNIT_TARGET_HERO | DOTA_UNIT_TARGET_BASIC"" & @CRLF & _
" "AbilityUnitDamageType" "DAMAGE_TYPE_MAGICAL"" & @CRLF & _
" "SpellImmunityType" "SPELL_IMMUNITY_ENEMIES_NO"" & @CRLF & _
" "FightRecapLevel" "1"" & @CRLF & _
" "AbilityTextureName" "rooting_shoot"" & @CRLF & _
"" & @CRLF & _
" // Casting" & @CRLF & _
" //-------------------------------------------------------------------------------------------------------------" & @CRLF & _
" "AbilityCastRange" "500"" & @CRLF & _
" "AbilityCastPoint" "0.3 0.3 0.3 0.3"" & @CRLF & _
" " & @CRLF & _
" // Time " & @CRLF & _
" //-------------------------------------------------------------------------------------------------------------" & @CRLF & _
" "AbilityCooldown" "9.0 8.0 7.0 6.0"" & @CRLF & _
"" & @CRLF & _
" // Cost" & @CRLF & _
" //-------------------------------------------------------------------------------------------------------------" & @CRLF & _
" "AbilityManaCost" "115 125 140 150"" & @CRLF & _
"" & @CRLF & _
" // Stats" & @CRLF & _
" //-------------------------------------------------------------------------------------------------------------" & @CRLF & _
" "AbilityModifierSupportValue" "0.5" // Applies multiple modifiers" & @CRLF & _
" " & @CRLF & _
" // Special" & @CRLF & _
" //-------------------------------------------------------------------------------------------------------------" & @CRLF & _
" "AbilitySpecial"" & @CRLF & _
" {" & @CRLF & _
" "01"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_INTEGER"" & @CRLF & _
" "damage_per_second_tooltip" "50"" & @CRLF & _
" }" & @CRLF & _
" "02"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_FLOAT"" & @CRLF & _
" "duration_tooltip" "1.5 2.0 2.5 3.0"" & @CRLF & _
" }" & @CRLF & _
" "03"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_INTEGER"" & @CRLF & _
" "hero_damage_tooltip" "150 200 250 300"" & @CRLF & _
" }" & @CRLF & _
" "04"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_FLOAT"" & @CRLF & _
" "creep_duration_tooltip" "10.0 10.0 10.0 10.0"" & @CRLF & _
" }" & @CRLF & _
" "05"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_INTEGER"" & @CRLF & _
" "creep_damage_tooltip" "1000"" & @CRLF & _
" }" & @CRLF & _
" "06"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_FLOAT"" & @CRLF & _
" "damage" "100"" & @CRLF & _
" }" & @CRLF & _
" // Extra variable" & @CRLF & _
" "07"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_FLOAT"" & @CRLF & _
" "stun_duration" "0.1"" & @CRLF & _
" }" & @CRLF & _
" "08"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_FLOAT"" & @CRLF & _
" "damage_interval" "0.5"" & @CRLF & _
" }" & @CRLF & _
" "09"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_INTEGER"" & @CRLF & _
" "damage_per_second" "25"" & @CRLF & _
" }" & @CRLF & _
" "10"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_FLOAT"" & @CRLF & _
" "duration" "1.0 1.5 2.0 2.5"" & @CRLF & _
" }" & @CRLF & _
" "11"" & @CRLF & _
" {" & @CRLF & _
" "var_type" "FIELD_FLOAT"" & @CRLF & _
" "creep_duration" "9.5 9.5 9.5 9.5"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" // Data driven" & @CRLF & _
" //-------------------------------------------------------------------------------------------------------------" & @CRLF & _
" "precache"" & @CRLF & _
" {" & @CRLF & _
" "soundfile" "soundevents/game_sounds_heroes/game_sounds_crystalmaiden.vsndevts"" & @CRLF & _
" "particle" "particles/leave_bite/leave_bite_06.vpcf"" & @CRLF & _
" "particle" "particles/leave_bite/leave_bite_01.vpcf"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "OnSpellStart"" & @CRLF & _
" {" & @CRLF & _
" "TrackingProjectile"" & @CRLF & _
" {" & @CRLF & _
" "Target" "TARGET"" & @CRLF & _
" "EffectName" "particles/leave_bite/leave_bite_01.vpcf"" & @CRLF & _
" "MoveSpeed" "2000"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "Stun"" & @CRLF & _
" {" & @CRLF & _
" "Target" "TARGET"" & @CRLF & _
" "Duration" "%stun_duration"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "ApplyModifier"" & @CRLF & _
" {" & @CRLF & _
" "Target"" & @CRLF & _
" {" & @CRLF & _
" "Center" "TARGET"" & @CRLF & _
" "Types" "DOTA_UNIT_TARGET_HERO"" & @CRLF & _
" }" & @CRLF & _
" "ModifierName" "modifier_frost_bite_root_datadriven"" & @CRLF & _
" "Duration" "%duration"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "ApplyModifier"" & @CRLF & _
" {" & @CRLF & _
" "Target"" & @CRLF & _
" {" & @CRLF & _
" "Center" "TARGET"" & @CRLF & _
" "Types" "DOTA_UNIT_TARGET_HERO"" & @CRLF & _
" }" & @CRLF & _
" "ModifierName" "modifier_frost_bite_damage_datadriven"" & @CRLF & _
" "Duration" "%duration"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "ApplyModifier"" & @CRLF & _
" {" & @CRLF & _
" "Target"" & @CRLF & _
" {" & @CRLF & _
" "Center" "TARGET"" & @CRLF & _
" "Types" "DOTA_UNIT_TARGET_BASIC"" & @CRLF & _
" }" & @CRLF & _
" "ModifierName" "modifier_frost_bite_root_datadriven"" & @CRLF & _
" "Duration" "%creep_duration"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "ApplyModifier"" & @CRLF & _
" {" & @CRLF & _
" "Target"" & @CRLF & _
" {" & @CRLF & _
" "Center" "TARGET"" & @CRLF & _
" "Types" "DOTA_UNIT_TARGET_BASIC"" & @CRLF & _
" }" & @CRLF & _
" "ModifierName" "modifier_frost_bite_damage_datadriven"" & @CRLF & _
" "Duration" "%creep_duration"" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "FireSound"" & @CRLF & _
" {" & @CRLF & _
" "Target" "TARGET"" & @CRLF & _
" "EffectName" "hero_Crystal.frostbite"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "Modifiers"" & @CRLF & _
" {" & @CRLF & _
" "modifier_frost_bite_root_datadriven"" & @CRLF & _
" {" & @CRLF & _
" "IsPurgable" "1"" & @CRLF & _
" " & @CRLF & _
" "EffectName" "particles/leave_bite/leave_bite_06.vpcf"" & @CRLF & _
" " & @CRLF & _
" "States"" & @CRLF & _
" {" & @CRLF & _
" "MODIFIER_STATE_ROOTED" "MODIFIER_STATE_VALUE_ENABLED"" & @CRLF & _
" "MODIFIER_STATE_INVISIBLE" "MODIFIER_STATE_VALUE_DISABLED"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "modifier_frost_bite_damage_datadriven"" & @CRLF & _
" {" & @CRLF & _
" "IsPurgable" "1"" & @CRLF & _
" "IsHidden" "1"" & @CRLF & _
" " & @CRLF & _
" "OnCreated"" & @CRLF & _
" {" & @CRLF & _
" "Damage"" & @CRLF & _
" {" & @CRLF & _
" "Target" "TARGET"" & @CRLF & _
" "Damage" "%damage_per_second"" & @CRLF & _
" "Type" "DAMAGE_TYPE_MAGICAL"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" "ThinkInterval" "%damage_interval"" & @CRLF & _
" "OnIntervalThink"" & @CRLF & _
" {" & @CRLF & _
" "Damage"" & @CRLF & _
" {" & @CRLF & _
" "Target" "TARGET"" & @CRLF & _
" "Damage" "%damage_per_second"" & @CRLF & _
" "Type" "DAMAGE_TYPE_MAGICAL"" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")