using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(N'.*?')";
string input = @"16588, 16503, 1, 1, N'1, 2, 3 RUE MENESTRELS', 12, 153";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}