package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(N'.*?')`)
var str = `16588, 16503, 1, 1, N'1, 2, 3 RUE MENESTRELS', 12, 153`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}