Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
^download\/(?P<doc>[^\/]+)[|\/]{0,1}(?P<mode>[\w]{0,})[|\/]{0,1}$
"
gm
Input 1
1
New
download/uuid_file.pdf/modeset1 download/uuid_file.pdf/modeset1/ download/uuid_file.pdf/ download/uuid_file.pdf