$re = '/([\w\(\),@\'\/-])/m';
$str = 'ABcd()ef,/\'-@sdf
ABcd(),
ABcddfg ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);