$re = '/^(?:0|63)?\d{10}\b/m';
$str = '09187654321
09187654321
6311111111
631111111111
06311111111
63111111111
011111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);