import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<host>[a-z0-9.\\-_]+(?<port>:\\d+)?\\/)?(?<ns>[a-z]+\\/)?(?<repo>[a-z\\-])+:(?<tag>[\\w.\\-])+$";
final String string = "alpine:3.7\n"
+ "pse/anabroker:latest\n"
+ "mysql/mysql-server:8.0.27\n\n"
+ "docker.example.com/gmr/alpine:3.7\n"
+ "docker.example.com:5000/gmr/alpine:latest\n\n"
+ "z86jw44v.mirror.aliyuncs.com/library/mysql:8.0.27\n"
+ "z86jw44v.mirror.aliyuncs.com/library/debian:stretch-slim";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}