$re = '/>>>\d+\s(.*?)(?=>>>)/';
$str = '>>>15 text>>>67 text2>>>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);