package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://(\S+\.)+\S+(/\S+)*/?`)
var str = `https://t.co/8OMryrUVET
https://regex101.com/
https://www.google.com/search?client=firefox-b-d&q=nltk+string+cleaning
https://machinelearningmastery.com/clean-text-machine-learning-python/
py New Year from #MarALago! Thank you to my...
4 Well the year has officially begun. I have man...
5 I will be going to Mississippi tomorrow night ...
6 The person that Hillary Clinton least wants to...
7 Thank you so much to https://t.co/8OMryrUVET f...
8 #VoteTrump2016 & together we will #MakeAmerica...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}