use strict;
my $str = 'https://t.co/8OMryrUVET
https://regex101.com/
https://www.google.com/search?client=firefox-b-d&q=nltk+string+cleaning
https://machinelearningmastery.com/clean-text-machine-learning-python/
py New Year from #MarALago! Thank you to my...
4 Well the year has officially begun. I have man...
5 I will be going to Mississippi tomorrow night ...
6 The person that Hillary Clinton least wants to...
7 Thank you so much to https://t.co/8OMryrUVET f...
8 #VoteTrump2016 & together we will #MakeAmerica...';
my $regex = qr/https?://(\S+\.)+\S+(/\S+)*/?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}