// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^```\h*(\S+)").unwrap();
let string = "Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line
Do not change this line
```markdown
Sasha great!
Sasha nice!
She is beautiful, surprise!
Do not change this line";
let substitution = "<!-- language: lang-\\1 -->\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}