Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(Armor.)([a-zA-Z]+)(, Surface.)([a-zA-Z]+)(, name)
/
g
Input 1
1
New
internal CruiserTorpedo(Player owner) : this(owner, "") { } internal CruiserTorpedo(string name) : base("Torpedo Cruiser", new UnitDimensions(4), new List<Weapon> { new ShipGunSmall(0, 0), new ShipGunSmall(0, 1), new TorpedoTube(0, 2), new AAAGun(0, 3) }, Armor.Light, Surface.Water, name) { }
Substitution
$1$2$3$4, 1$5