// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Armor.)([a-zA-Z]+)(, Surface.)([a-zA-Z]+)(, name)").unwrap();
let string = "internal CruiserTorpedo(Player owner) : this(owner, \"\") {
}
internal CruiserTorpedo(string name) : base(\"Torpedo Cruiser\",
new UnitDimensions(4),
new List<Weapon> { new ShipGunSmall(0, 0), new ShipGunSmall(0, 1), new TorpedoTube(0, 2), new AAAGun(0, 3) },
Armor.Light, Surface.Water, name) {
}";
let substitution = "$1$2$3$4, 1$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}