package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*[\\/\\\\])([-\w]+$)`)
var str = `/Hello/Stack/Overflow
/when/I/try/this
C:\on\VS_Code
C:\it\does\not\work
/can you
C:\help\me?
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}