const regex = /^(?=(.+)\1+(.+)\2+$)(?!\1++$)(?=(.(?:(?-1)|(?=\2+$)).)$)(\1(?-1)?\2)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(.+)\\1+(.+)\\2+$)(?!\\1++$)(?=(.(?:(?-1)|(?=\\2+$)).)$)(\\1(?-1)?\\2)$', 'gm')
const str = `ab
a
aaaaaaaaaaaaaaabbbbbbbb
bba
aaaacbbb
foobarfoo
foofoobar
aaabbb
aabb
aaaaaaaabbbbbbbb
foofoobarbar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}