$re = '/^(?=(.+)\1+(.+)\2+$)(?!\1++$)(?=(.(?:(?-1)|(?=\2+$)).)$)(\1(?-1)?\2)$/m';
$str = 'ab
a
aaaaaaaaaaaaaaabbbbbbbb
bba
aaaacbbb
foobarfoo
foofoobar
aaabbb
aabb
aaaaaaaabbbbbbbb
foofoobarbar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);