re = /^(?=(.+)\1+(.+)\2+$)(?!\1++$)(?=(.(?:(?-1)|(?=\2+$)).)$)(\1(?-1)?\2)$/m
str = 'ab
a
aaaaaaaaaaaaaaabbbbbbbb
bba
aaaacbbb
foobarfoo
foofoobar
aaabbb
aabb
aaaaaaaabbbbbbbb
foofoobarbar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end