re = /^(.+)\R(?:\1(?:\R|$))+/m
str = '192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.1
192.168.0.2
192.168.0.3
192.168.0.3
192.168.0.4
192.168.0.5
192.168.0.5
192.168.0.6'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result