const regex = /\b(?!333333\b)\d{6}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!333333\\b)\\d{6}\\b', 'gm')
const str = `333333 123456 333333,123456!Vasya1234560000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}