# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(((::){0,1}[_A-z][_A-z0-9]*)+)$/$1/gm;t' <<< "monkey
dog
dog8_
_dog8
8dog_
::std
::monkey
::monkey::dog::cat
::monkey::8dog::cat
::frog
::7frog
boost::asio
::boost::asio"