import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((::){0,1}[_A-z][_A-z0-9]*)+)$";
final String string = "monkey\n"
+ "dog\n"
+ "dog8_\n"
+ "_dog8\n"
+ "8dog_\n"
+ "::std\n"
+ "::monkey\n"
+ "::monkey::dog::cat\n"
+ "::monkey::8dog::cat\n"
+ "::frog\n"
+ "::7frog\n"
+ "boost::asio\n"
+ "::boost::asio";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}