import Foundation
let pattern = #"^(((::){0,1}[_A-z][_A-z0-9]*)+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
monkey
dog
dog8_
_dog8
8dog_
::std
::monkey
::monkey::dog::cat
::monkey::8dog::cat
::frog
::7frog
boost::asio
::boost::asio
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)