$re = '/^https?:\/\/(.*?)\/.*$/m';
$str = 'https://api.github.com/rest/getusername
http://api.google.com/rest/getusername
ftp://api.whatever.com/rest/getusername';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);