import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:https?:\\/\\/)?(?:www\\.)?.*?\\.com(?!\\/(?:team|forum))\\S*";
final String string = "website.com/team\n"
+ "website.com/forum\n"
+ "http://website.com/team\n"
+ "https://website.com/forum\n"
+ "https://website.com/forum/test\n\n"
+ "https://www/website.com\n"
+ "http://website.com\n"
+ "website.com/test\n"
+ "website.com\n"
+ "website.com/\n"
+ "http://website.com\n"
+ "https://website.com\n"
+ "https://www.website.com\n"
+ "http://website.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}