$re = '/\b(?:https?:\/\/)?(?:www\.)?.*?\.com(?!\/(?:team|forum))\S*/m';
$str = 'website.com/team
website.com/forum
http://website.com/team
https://website.com/forum
https://website.com/forum/test
https://www/website.com
http://website.com
website.com/test
website.com
website.com/
http://website.com
https://website.com
https://www.website.com
http://website.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);