const regex = /^((?:(?:http|ftp|ws)s?|sftp):\/\/?)?([^:/\s.#?]+\.[^:/\s#?]+|localhost)(:\d+)?((?:\/\w+)*\/)?([\w\-.]+[^#?\s]+)?([^#]+)?(#[\w-]*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:(?:http|ftp|ws)s?|sftp):\\\/\\\/?)?([^:\/\\s.#?]+\\.[^:\/\\s#?]+|localhost)(:\\d+)?((?:\\\/\\w+)*\\\/)?([\\w\\-.]+[^#?\\s]+)?([^#]+)?(#[\\w-]*)?$', 'gm')
const str = `https://localhost:8000/dir/1/2/search.html?k1=v1&k2=v2&k3#hash
https://unitaire2.dpo.fprod/jira`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}