const regex = /^(\d*)?([ ])?((\d{3})|\(\d{3}\))([- ])?(\d{3})([- ])?(\d{4})$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*)?([ ])?((\\d{3})|\\(\\d{3}\\))([- ])?(\\d{3})([- ])?(\\d{4})$', 'mg')
const str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
800-692-7753
8oo-six427676;laskdjf
1 555-555-5555
1 (555) 555-5555
5555555555
555-555-5555
(555)555-5555
1(555)555-5555
555-5555
5555555
1 555)555-5555
1 555 555 5555
1 456 789 4444
123**&!!asdf#
55555555
(6054756961)
2 (757) 622-7382
0 (757) 622-7382
-1 (757) 622-7382
2 757 622-7382
10 (757) 622-7382
27576227382
(275)76227382
2(757)6227382
2(757)622-7382
555)-555-5555
(555-555-5555
(555)5(55?)-5555
55 55-55-555-5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}