$re = '/([A-Z](?![a-z]))|([A-Z][a-z])/m';
$str = 'Fe(NO3)2
H2O
Mg(OH)2
K4[ON(SO3)2]2
K4{ON(SO3)2}2
K4ON(SO3)2ON(SO3)2
Mg3
Xe34A
MgOHOH
HHO
MgOHOH
KKKKONSOOOSOOOOMgNSOOOSOOO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);